Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

ListView script does not work in SIT

SA-65233

Summary



A ListView configured  with a fragment for script functions does not work in the SIT environment. This works in the DEV environment.


Error Messages



Not Applicable


Steps to Reproduce

  1. Log in to the application with a Developer ID.
  2. Configure a ListView with a fragment included for script functions. 
  3. Include the doSingleClick script function in the fragment.
  4. Invoke this through the SingleClickEvent
  5. Open the ListView.
  6. Run the ListView.


Root Cause



In the SIT system, the ListView opens in the Internet Explorer 5 browser, while in the DEV it opens in Internet Explorer 11 browser.


Resolution



SIT URL has compatibility settings that causes the Internet Explorer browser to render in the Compatibility mode.

The working URL has the user agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) such as Gecko.

The non-working SIT URL has user agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E; InfoPath.3; MS-RTC LM 8; SLCC2; TD_LCK_V80_01

As a local-change, delete the compatibility settings.



 

Published December 17, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us