Support Article

Load Tester user cannot log in using Apache JMeter

SA-36596

Summary



User set up an Operator ID in production for load testing.

The user is able to log in to the production environment when using the load tester Operator ID but cannot log in when using the testing tool Apache JMeter.


Error Messages



Not Applicable


Steps to Reproduce



Unknown


Root Cause



A defect or configuration issue in the operating environment
Because the log-in is through a third-party tool (Apache JMeter), the Pega rules cookie is not getting authenticated as subsequent requests are made.

Resolution



Perform the following change to your environment:
  1. Edit the prconfig.xml file to include the following setting:
    <env name="authentication/UsePreAuthenticationCookie" value="true"/>
  2. After making this change, you can use Apache JMeter tool to log in to the application as the load tester.

Published April 17, 2017 - Updated October 10, 2017


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