Support Article
Loading a knowledge article for display in portal takes 4 sec
SA-69231
Summary
When opening a knowledge article from the Pega portal (for example, KMHelpSiteListAllArticles), the article takes between four seconds to display on the screen.
Error Messages
Not Applicable
Steps to Reproduce
- Browse through the categories in the taxonomy.
- Click the link to open a specific article.
Root Cause
When selecting an article (FetchArticle) to open, a large amount of activity steps with multiple loops within loops initiated through the D_KMArticlesWithTaxonomy, are triggered. The FetchArticles activity for each loop also has several loops within loops. This is only to retrieve the data of the article selected in the link.
Resolution
Apply HFix-49216.
Published December 29, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.