Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Locale is read incorrectly while importing decimal values



In the Pega Sales Automation application, while performing a Bulk Import of Quotes, locale is read incorrectly for premium fields in the Excel sheet. This occurs when the locale is set to Dutch.

Error Messages

Validate mislukt: Erros Detected. .PropertyName123.45,67 is geen geldoge decimal

Steps to Reproduce

  1. Set operator locale to nl_NL 
  2. Upload a CSV file to create Bulk Import Opportunity in Sales Automation.
  3. In the CSV file, have a decimal property in Dutch premium format (123.45,25).

Root Cause

A defect in Pegasystems’ code or rules.

The decimal value in CSV is in nl_NL locale format. Dictionary validation occurs when Skip validation is unchecked during import. Dictionary validation does not consider the locale and invalidates the format.


Apply HFix-46057.


Published December 12, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us