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Support Article

Lock is acquired on clicking the Back button on a Screenflow

SA-87698

Summary



A case type is configured with Optimistic locking. The lock is acquired when user clicks the Back button on the screen flow. When the work object is opened for processing, by User2, an error occurs indicating that the lock is with User1. Service Level Agreement (SLA) agent also fails in processing as the lock is with the User1.


Error Messages



Cannot obtain a lock on instance, as requestor already has the lock.


Steps to Reproduce

  1. Configure cases with Optimistic locking
  2. Create a screen flow with two assignments
  3. Go to the second assignment as User1
  4. Click the Back button to move to the first assignment
  5. Open the work object as User2. The first assignment opens
  6. Click the Next button. Error occurs


Root Cause



A defect in Pegasystems’ code or rules. The lock is not released on clicking the Back button on the screen flow. This occurs while using Optimistic locking. 

Resolution



Apply HFix-56151.

 

Published October 8, 2020

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