Support Article
Lock error in log file with PRPC 6.1 SP2
SA-31362
Summary
The below error gets logged thousands of times in the system.out log file. Users also experience command failure.
Error Messages
The lock "MYCO-FW-GD-DATA-SERVICEINVOCATIONLOG <your_itemID>" was still fresh for requestor <your_requestorID>, but now appears to be missing.
Steps to Reproduce
Application needs to rapidly (multiple requests within 1/4 second) request the same lock on the same record.Among the many ways to do this, adding a Declare-Trigger rule to update and lock the record already being saved can do this.
Root Cause
A defect in Pegasystems’ code or rules.
In the PRPC 6.2 product, requesting a lock on a record for which you already had the lock issued an extension of the expiration time.
Multiple lock requests made sequentially and very rapidly issued multiple requests for extending the same lock, referencing as part of the WHEN clause the original extension time.
When fired sequentially, the second extension request was looking for a lock with the original extension time; this no longer was in the database, as the first extension request had modified the expiration time by the time the second request fired.
Resolution
Apply HFix-30695.
This eliminates the WHEN clause restricting the update to an existing lock with a given expiration time.
The expiration time is no longer considered when going out to update the lock.
Published December 19, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.