Support Article
Logging option not available for Connect-SOAP response
SA-37119
Summary
Developers would like to see the SOAP response message for diagnostic purposes in a Connect-SOAP.
Error Messages
Not Applicable
Steps to Reproduce
1. Set the logger for invokeaxis2 to 'All'.
2. Invoke any connector for SOAP request. While this captures the request message and other diagnostic information, the response message is not captured.
Root Cause
A defect in Pegasystems’ code or rules. The code to log the response envelope is missing.
Resolution
Perform the following local-change step.
Add the following two lines to step 16 of the InvokeAxis2 activity:
if (oLog.isDebugEnabled())
oLog.debug("SOAP Response Envelope:\n" + soapEnvelope);
Published May 15, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.