Support Article
Long JVM startup time after upgrade to Pega 7.1.7
SA-9845
Summary
In the process of upgrade from PRPC 6.1 SP2 system to Pega 7.1.7, user observes a significant increase in the amount of time taken by the JVM to startup approximately upto 2 hours.
Once the JVM starts, it works fine.
Error Messages
No error message - just a long time waiting for the JVM to start:
Start Time: 13:37
Finish Time: 15:33
No activity in the logs between the following times:
13:49 – 14:15
14:15 – 14:48
14:58 – 15:22
Steps to Reproduce
Start up PRPC 7.1.7 JVM (previously upgraded from PRPC 6.1 SP2) with the prerequisites:
*Database is Microsoft SQL Server 2012.
*Application Server is Websphere 7.0.
*Minimum and Maximum Heap Size set to 8.0GB
Root Cause
Elastic Search is unable to get a lock on the node file. It tries multiple times and this takes about 30 minutes, before it moves on and hence the long waiting for the JVM to start-up.
Resolution
This issue is resolved through the following Local-change:
The rpc.stad daemon does not run because the files cannot be successfully locked on the directory that is used to store rules index files.
When the environment is restarted and the rpc.statd daemon works fine and the problem gets resolved.
Published June 12, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.