Support Article
Lucene text search for work objects not working
SA-650
Summary
The Lucene text search for work objects is not working properly from the Case Manager portal. Application users attempting to search see the error message.
Error Messages
Target host must not be null or set in Parameters.
Steps to Reproduce
Start Case Manager 7 and perform a search.
Root Cause
Software use or operation error
The Dynamic System Settings (DSS) were not correctly specified for the system node, system name, and search folder. After the DSS were corrected, the search worked as expected but did not find any work objects. Search did not find any work objects because the workpools and class groups were not correctly defined.
Resolution
- Specify the correct Dynamic System Settings (DSS) in the Search landing page to ensure proper functioning of Lucene text search:
Note: Only one node acts as the indexing node with Lucene text search.
indexing/enabled = true
indexing/explicitIndexDir = C:\your_file_path
indexing/hostid = 2e19010ac5846cc9339b7fbe88ba7e7c
indexing/hostname = Your_Server_Name
Note: The indexing/hostid value is a 32-character alpha-numeric hash code that represents your system node ID. Find this value on the pxProcess clipboard page for the property pxSystemNodeId.
- Resolve additional issues by changing the class group model.
Published May 3, 2016 - Updated October 8, 2020
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