Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Mail notification does not save

SA-55729

Summary



When using the mail notification (Send Email) in Case Designer, the message text can be entered, however, the entered text does not save on saving it. This occurs only with Japanese font.


Error Messages



Value cannot be blank


Steps to Reproduce

  1. Open any flow and create a Send Email Smart Shape . 
  2. Change the Utility name to Japanese text.
  3. Select the Click to edit message option. 
  4. Enter text in the popup which displays.
  5. Click Submit.
  6. Navigate away from that step in Case Designer.
  7. Return to the step. The text is not saved.


Root Cause



A defect in Pegasystems’ code or rules.

When multibyte characters are used in the Send Email shape, a Rule-Obj-Corr class instance is created internally with the stream name as the label provided in the Send Email shape. Hence, when the same shape is modified, a check is performed internally for any duplicate entry in the database with the same keys. This check fails to provide the correct result. This is because the internal database APIs return records from the database without these multibyte characters. Therefore, object comparison fails.


Resolution



Perform the following local-change:
  1. Create a new Send Email shape.
  2. Do not modify the utility name to Japanese.
  3. Save as it is in English characters. 
  4. Save the flow.
  5. Change the Send Email utility name. 
An enhancement request, FDBK-25956, is created for consideration by Pega Product Management.


 

Published September 5, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us