Support Article
Mail notification does not save
SA-55729
Summary
When using the mail notification (Send Email) in Case Designer, the message text can be entered, however, the entered text does not save on saving it. This occurs only with Japanese font.
Error Messages
Value cannot be blank
Steps to Reproduce
- Open any flow and create a Send Email Smart Shape .
- Change the Utility name to Japanese text.
- Select the Click to edit message option.
- Enter text in the popup which displays.
- Click Submit.
- Navigate away from that step in Case Designer.
- Return to the step. The text is not saved.
Root Cause
A defect in Pegasystems’ code or rules.
When multibyte characters are used in the Send Email shape, a Rule-Obj-Corr class instance is created internally with the stream name as the label provided in the Send Email shape. Hence, when the same shape is modified, a check is performed internally for any duplicate entry in the database with the same keys. This check fails to provide the correct result. This is because the internal database APIs return records from the database without these multibyte characters. Therefore, object comparison fails.
Resolution
Perform the following local-change:
- Create a new Send Email shape.
- Do not modify the utility name to Japanese.
- Save as it is in English characters.
- Save the flow.
- Change the Send Email utility name.
Published September 5, 2018 - Updated October 8, 2020
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