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Support Article

Marketing profile landing page does not work

SA-26215

Summary



User has issues with the Marketing Profile report of a customer when logged into the Pega Marketing Portal.

The error says that the customer is not found even when the customer is present in the Spine table. The Marketing Schema has the customer Spine which is an external table. The property is also exposed.

Error Messages



2016-06-27 10:47:13,868 [ WebContainer : 6] [fileThread] [ ] [ <ApplicationName>:01.01.01] ( rd.resolve.SqlReportResolver) ERROR <URL-OperatorName> - An error occured during resolving the report definition - InvalidReferenceException .pyFullName Unexposed properties cannot be selected for classes mapped to external tables
com.pega.pegarules.data.internal.rd.reference.InvalidReferenceException: InvalidReferenceException .pyFullName Unexposed properties cannot be selected for classes mapped to external tables

Steps to Reproduce



1. Log in to Pega Marketing portal.
2. Click on Marketing Profile link under Reports menu.


Root Cause



The Customer Search Report Definition for Marketing Profile (MKTSearchResults) was not extended to the custom Customer class.

The column "Full Name" referred in the Report Definition "MKTSearchResults" is not available in the database table of the custom Customer class.


Resolution



The customer search Report Definition for Marketing Profile (MKTSearchResults) need to be extended to fulfil the specific search criteria.

1. Perform a Save As of MKTSearchResults Report Definition from 'PegaMKT-Data-Customer' class to custom Customer class


2. Edit the columns based on the requirement.
3. Perform a Save As of “MKTProfileSearchRD” Activity to custom Application specific Ruleset and update the Activity for step 2 as shown below: Update the Property value to “Declare_MKTSystemSetting.CustomerClassName



4. Check in the changes and perform the Marketing Profile search.

Published August 23, 2017 - Updated December 2, 2021

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