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Support Article

Mismatch in the Segment count and wireless output count

SA-2225

Summary



Mismatch in the Segment count and final output quantity

Error Messages



While executing the dynamic campaign we are getting multiple sms for signal offer , however there is single entry in segment for particular no.


Steps to Reproduce



While executing the dynamic campaign we are getting multiple sms for signal offer , however there is single entry in segment for particular no.


Root Cause



The mismatch in the Segment count and wireless output count can occur due to additional columns in the Extract Template from tables which are not included in the stored fields of the Segment. Such tables can have no matching records for all the A1's present in the Segment. As these additional tables and their columns are joined only during the output stage, the mismatch will be noticed in the Campaign output.

Resolution



- In segment storedfield section, use all the columns which are used in ExtractTemplate as stored fields
- Dedupe on A1/Type 1 column and execute the segment
- In extract Template, use all columns FieldType as Stored Field
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

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