Support Article
Missing database connection importing pzFCMR_7_1_2.jar for cpmfs
SA-7964
Summary
User has successfully installed Pega 7.1.7 and Customer Process Manager (CPM) 7.1.3 which are prerequisites for installing CPM for Financial Services (CPMFS).
User is trying to import AdditionalProducts\pzFCMR_7_1_2.jar per the CPMFS 7.1.3 Installation Guide
On the step to import the pzFCMR_7_1_2.jar it is complaining about a missing database connection for the FCMR datasource. There is nothing in the install guide which tells you to add this datasource.
Error Messages
Missing or invalid database connections
Missing database connection
FCMR
Steps to Reproduce
Import pzFCMR_7_1_2.jar
Root Cause
The root cause of this problem is an error/omission in product documentation for CPMFS installation document. The documentation does not include instructions for installing CPMFS on a Federated Case Management (FCM) system nor does it include instructions for installing on a system without FCM.
Resolution
Documenation update has been requested and will be updated in next release.
If you wish to install CPMFS on a FCM System the release notes from pdn are located at:
https://pdn.pega.com/documents/federated-case-management-71-release-notes
The references the setup guide located at:
https://pdn.pega.com/federated-case-management/setting-up-and-configuring-federated-case-management
To install CPMFS without FCM one should skip importing the pxFCMR_7_1_2.jar.
Once the CPMFS application is installed, go into the Application and remove the references to the FCM & IAC rule-set.
Published March 11, 2016 - Updated December 2, 2021
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