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Support Article

Mobile app fails to connect in Staging environment in OSCO

SA-20064

Summary



Mobile application users are encountering HTTP 500 "Internal server error" messages on their devices. This issue appears to impact Online as a Special Case of Offline (OSCO) mobile functionality.


Error Messages



"HTTP 500 Internal Server error"


Steps to Reproduce



This issue only occurs when the device is connected to WiFi / network:

Run an application on the mobile client with a breakout call to access the server and execute an activity there.


Root Cause



A defect in Pegasystems’ code or rules. 

The working server is configured to answer requests for both the following URLs.

Notice the additional PRServlet in the second URL.
  https://dev.<customer>.com/prweb
  https://dev.<customer>.com/prweb/PRServlet

On the malfunctioning system, any request to:
  https://stage.<customer>.com/prweb
(without the PRServlet) is generating the 500 server errors (even in desktop browser).
 

Resolution



Perform the following local-change: 

Configure the application server on the staging system, to answer both the requests (with and without PRServlet) as it is in the working system.

 

Published March 12, 2016 - Updated October 8, 2020

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