Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Mobile device does not receive push notifications

SA-50562

Summary



Mobile application does not receive push notification.


Error Messages

Not Applicable


Steps to Reproduce

  1. Register to the Google Cloud Messaging (GCM) service
  2. Provide the required credentials in Pega application to send the notification
  3. Configure push notification in the mobile application
  4. Send a notification to the mobile application


Root Cause



The package naming convention was not adhered when setting the App ID (package name).

Resolution



Correct the App ID to adhere to the package naming convention.
The elements must be delimited by a "." and all elements, until the last element, must be in lowercase alphabets. For example, com.pega.MyApp qualifies but com.pega.MyApp.Inventory does not.

Published February 14, 2018 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us