Support Article
Mobile SSO does not work in Offline mode
SA-106207
Summary
A mobile application is configured to login using Single Sign-on (SSO) that uses the SAML Authentication. When the application is not connected to the network, it does not work as an Offline application.
Error Messages
Not Applicable
Steps to Reproduce
- Configure a mobile channel.
- Build an Android or iOS application with an SSO URL.
- Install the mobile application .
- Launch the mobile application.
- Log in to the application in the Online mode.
- Close the application.
- Turn off the Internet on the mobile device.
- Relaunch the application.
Root Cause
A defect or configuration issue in the operating environment: Incorrect Offline setup.
Resolution
Perform the steps provided to configure the Offline application to use SSO, https://community.pega.com/knowledgebase/articles/configuring-mobile-app-use-external-login-openid-connect-or-saml-protocol-pega-81
Published June 17, 2020 - Updated December 2, 2021
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