Support Article
Modified alert is not saved in system after modifying the alert
SA-63202
Summary
Modified alert is not saved in the system after modifying an alert message in the 'Alerts and Messages' widget.
Error Messages
Not Applicable.
Steps to Reproduce
- Launch the portal
- Create an alert in the 'Alert and Messages' section
- Modify the created alert and check the system
Root Cause
A defect in Pegasystems’ code or rules.
An issue in the upgrade script of MS SQL. The PCA_ALERTS table in the script has all column names in uppercase letters. As MS SQL columns are case sensitive, the queries fail.
Resolution
Perform the following local-change:Update the below columns to Camel case:
- pzInsKey
- pzPVStream
- pxObjClass
- pxInsName
- pxSaveDateTime
- pxCommitDateTime
- pxCreateDateTime
- pxUpdateDateTime
- pxCreateOperator
- pxCreateOpName
- pxCreateSystemID
- pxUpdateDateTime
- pxUpdateOperator
- pxUpdateOpName
- pxUpdateSystemID
- pyLabel
- pyID
- pxCoverInsKey
- pxCoveredCount
- pxCoveredCountOpen
Published August 24, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.