Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

MongoDB to PostgreSQL data migration fails in Pega Chat

SA-66995

Summary



Pega Chat 7.22.10 is updated to Pega 7.4.7.

Since Pega Chat 7.4.7 only supports PostgreSQL 9.5.x, the existing data is migrated from MongoDB to PostgreSQL. Despite the completion of the Migration process, validation error occurs.

On checking in PostgreSQL, the Chats, companies, and queues are migrated; however, the user records are not migrated from MongoDB to PostgreSQL.



Error Messages



Validation Failed "Data mismatch for user.id.Record Id [].


Steps to Reproduce

  1. Install PostgreSQL 9.5.x.
  2. Execute the postgres.sql to set up the required relations for the chat.
  3. Edit the config.js in the Installation media/db-migrations folder with the source and destination details.
  4. Run the Node Package Manager (NPM) install to download the dependencies.
  5. Execute Installation media/db-migrations/migration-7.3/index.js.


Root Cause



This behavior is as per Pega product design.


Resolution



Here’s the explanation for the reported behavior:

The data is migrated correctly from MongoDB to PostgresSQL. However, the incorrect schema is referenced while querying the data.
Suggest Edit

Published April 4, 2019 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us