Support Article

MS Word Compatibility for 2016 Office 365

SA-38273

Summary



Office 365 Word Merge is not compatible with Pega 7.1.9.


Error Messages



Unrecognized Microsoft word version. Only Word 2010, 2007, 2003, 2002 and 2000 are supported.


Steps to Reproduce

  1. Install 2016 Office 365 on users desktop.
  2. Run Word edit use cases existing in production.
  3. Notice an incompatibility error and Word document does not open.


Root Cause



A defect in Pegasystems’ code or rules.

Resolution



Apply HFix-30766.

Additional instructions after the installing the HFix-30766 are :
  1. After installed this hotfix the client browser cache and temp files needed to be cleaned.
  2. Download the latest Silverlight control from this link (https://www.microsoft.com/getsilverlight/Get-Started/Install/Default.aspx)
  3. Close all Internet Explorer browser sessions on that user's system.
  4. Existing Silverlight prerequisites needs to be uninstalled. (System user needs Administrator privilege or with the help of IT admin) .
  5. Run the PegaSample WordEmbedMergeTest flow. PRPC will install latest Silverlight pre-requisites automatically.(Machine user needs Administrator privilege or with the help of IT admin) .
  6. Ensure whether Silverlight Prerequisites installed properly on this location (Control Panel\All Control Panel Items\Programs and Features) .
  7. If not installed then download form the pop-up window which was shown, when the WordEmbedMergeTest flow runtime.
  8. Now un-zip the cab file and install this prerequisites from installed file. (SLpreReqs.msi)
  9. Again re-run the WordEmbedMergeTest flow and test the WordMerge feature on Office-365 (Word-16) version.




Published May 19, 2017 - Updated June 7, 2017


100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.