Support Article
New rules do not appear in Find Rules reports
SA-7989
Summary
New rules created or imported into the system do not appear in Find Rules reports.
Error Messages
Not Applicable
Steps to Reproduce
1. Create a ruleset.
2. Create a rule in the ruleset.
3. In the Designer Studio menu, select Process and Rules > Tools > Find Rules > Find by Ruleset, Version, Rule Type.
Root Cause
The root cause of this problem is a defect or misconfiguration in the PRPC operating environment.
The database triggers, used to populate the pr_rule_vw table, were missing.
Resolution
Create the missing database triggers.
Published May 29, 2016 - Updated October 8, 2020
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