Support Article
Newly added products do not display on the drop down list
SA-83056
Summary
User adds new products to the Product Builder for Insurance (PBI) framework. However, while searching the values do not display on the dropdown list.
Error Messages
Not Applicable
Steps to Reproduce
- Disable the Search index of the system in the PBI framework
- Add a new product from the Catalog tab. The forms and coverage do not display on the dropdown list
Root Cause
To fetch results for forms and coverages list, the out-of-the-box fetchComponent activity which invokes the pxRetrieveSearchData activity is used. It creates elastic search query and fetches data from the report definition. Since the Search index is disabled in the application, elastic search query fetches null result.
In the Production environment, the search index is disabled and the fetchComponent activity invokes the BuildSearchQuery and pxRetrieveSearchData activities which require Search indices. When more components are present in an application, the case populates data from the data base. Each interaction consumes a lot of time and hence, this degrades the performance of the application. In these situations, user must leverage the out-of-the-box activity which takes care of the performance using the elastic search. If the number of components is not more, then the user must customize the activity by invoking the report definition with the required input parameters.
Resolution
Perform the following local-change:
Customize the fetchComponent activity by directly invoking the report definition with the required input parameters.
Published August 19, 2019 - Updated December 2, 2021
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