Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

No Application Rule Sets found for Saving as Rules

SA-37213

Summary



Currently user is developing on branch rule sets which doesn't contain applications rule sets. But when they select no branch, and try added to the base rule set the Application rule set is not showing rulesets for the user to saving the rules. Same is working fine when we select a branch for the saving as rules, the Application rulesets are visible.


Error Messages



Not Applicable

Steps to Reproduce

  1. Login into DesignerStudio
  2. Save as a rule by select 'No Branch' rule set on developing application.


Root Cause



An issue in the custom application code or rules While reviewing the tracer found that data page D_pzAvailableRuleSetsForRecord is responsible for loading the rulesets for the selected application. This data page isn't loaded correctly because of which a when condition in data transform pzSetBestAvailableRuleSetAndVersionForRecordContext of class "Rule-" was failing.

Resolution



Perform the following local-change:

Cleared the data page
D_pzAvailableRuleSetsForRecord manually by going to Load Management tab in DataPage landing page. After logging of fand logging backing in the reported issue was fixed.

Published May 6, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us