Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

No open ruleset versions available error when creating component

SA-74010

Summary



In the Developer portal, unable to create a new Component (despite following the instructions in the Help file).

For more information, refer to: https://community.pega.com/sites/default/files/help_v722/procomhelpmain.htm#sys%20mgmt/components/sm-create-new-component-tsk.htm

However, error occurs (when completing Step 6) though open rulesets are available and the user has the ability to create new rulesets.




Error Messages

No open ruleset versions available.




Steps to Reproduce

Follow the steps to add a component to an application:

  1. Click Designer Studio > Application > Components.
  2. Click New component.
  3. In the Label field, enter the name of the component. This label becomes the name of the component. 

    Optional: Click Edit to update the automatically-generated component name.

     
  4. Enter the version number.
  5. Click Create and open.
    The component ruleset name includes the first 13 characters of the component name and the creation time stamp. The ID also includes the version number.
  6. Enter a short description.

    Optional: Update the Publisher. The default value is the organization for the current logged-in user.
    Optional: Update the Component rulesets. Change the default ruleset or add rulesets to the component.
    Optional: List the required Prerequisites for this component. Prerequisites can include either applications or components.

     
  7. Click Save.


Root Cause



The system attempted to build or retrieve the pyRuleSet from the D_pzDefaultRuleContext. Error occurred because the pyRuleSet had a blank value.


Resolution



Perform the following local-change:
  1. Set a Default time configuration ruleset version (Advanced tab) to modify the access group .
  2. Log out and log in again for the changes to take effect.
 

Published April 7, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us