Support Article
No place to see error messages on Operator availability section
SA-6327
Summary
The developer portal and the user portal uses different rules to show the User availability.
In user portal, for User availability, there is no place to show the errors in the section, whereas in Dev portal there is a HTML table to show the errors.
Error Messages
Not Applicable
Steps to Reproduce
Launch user portal
Administrator-> Availability
Give any one of the start or end available dates
Click on Submit Button.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. A when condition on Page-Set-Messages is returning false and skipping a step(Page-Set-Messages) in an Activity rule "pySaveOperatorAvailability". This skipped step is the reason for the missing validation.
Resolution
This issue is resolved by hotfix item HFix-20695
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.