Support Article

None option is being displayed as blank value in summary view

SA-28778

Summary



The user has configured a Report definition as summary view. There is a column in the summary view which has blank values. When the user is trying to apply filter on the column, empty value is being displayed as Blank value in 7.x where as in 6.3 it was showing [none].


Error Messages



Not Applicable


Steps to Reproduce

  1. Configure a report definition and run the report
  2. Make sure one of the column has empty value. Apply filters on it.
  3. See that the blank value is shown as blank in the filter.


Root Cause



A software use or operation error : the property pyShowFilterUIBy is holding "" (empty) value. The rule pzUniqueValuesGridFields does not have "" empty check for pyShowFilterUIBy property

Resolution



Perform the following local-change:

a) Save as rule pyUniqueValuesGrid into application rule set.
b) Create a non auto-generated section and copy the code from pzUniqueValuesGridFields and append below else if condition in the code.

else if((tools.getParamValue("pyShowFilterUIBy").equals("") ) && ("".equals(tools.getProperty(".pyUILabel").getStringValue())) && ("".equals(tools.getProperty(".pySeparator").getStringValue()))) {
%><pega:lookup property=".pyCaption" value="NoValueLabel" />
<% }

c) Refer the section created in step (b) in place of pzUniqueValuesGridFields in section pyUniqueValuesGrid.

 

Published October 4, 2016 - Updated October 17, 2016

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.