Support Article
Not able to access Customer Properties in Stratergy
SA-11806
Summary
Developer have added a new column to the NBAM Customer class and mapped to a new property in Pega-OMF-ON-Data-Customer-BRG class.
This new property is used in a Strategy in a Filter component and then run a Program.
The value of the new property is not getting populated from customer table and therefore the strategy is not evaluating the offers correctly.
Error Messages
Not Applicable.
Steps to Reproduce
- Create a new property to the Customer class.
- In the external mapping tab of the customer class, map this property to a new column in the table.
- Reference the newly created property in the strategy and run an NBAM program.
Root Cause
The root cause of this problem is defect or misconfiguration in the operating environment.
The strategy execution uses Batch Input Configuration which is referencing the Segment report definition as source.
The data for the columns is populated, for use in the strategy, is picked from this report definition.
Because the report definition was not updated, the newly added column was not part of the report definition columns, hence no value was set for the property.
The report definition has to be updated by performing the re-save of the segment, that is, check-out and check-in the segment to regenerate the underlying report definition.
Resolution
This issue is resolved through the following local-change:
Performe check-out and check-in all the segments to regenerate the underlying report definition.
Also recommended to make this a general practice to resave the segments when any new Customer columns are added.
Tags:
Published September 1, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.