Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Not able to connect to Agile Studio Rest service from Dev

SA-81405

Summary



After upgrading to Pega 8.1.4, an error occurs when linking the application to Agile Studio using an API URL as below:

https://your_abc.pegacloud.net/prweb/PRRestService/api/v1



Error Messages



Enter a valid Agile Studio URL.




Steps to Reproduce

  1. Open the Application definition.
  2. Navigate to the Integration and Security tab.
  3. In the Agile Workbench's Integration section, click Configure integration.
  4. Enter the API URL in the modal window.
  5. Click Connect.


Root Cause



The error in the modal window is generic and is displayed for any error. Tracing the connect Click displayed a pyHTTPResponceCode with a Value of 401 for Step 7 in the pzTestConectivityForAgileStudio activity.




Resolution



For successful authentication of the API URL connection, perform the following:
  1. Configure PM_AgileStudio_AuthProfile authentication profile rule with a valid username and password for connection to the Agile Studio instance.


     
  2. Configure the Operator Preferences with the username to use to connect to Agile Studio.

Suggest Edit

Published August 19, 2019 - Updated December 2, 2021

Did you find this content helpful? Yes No

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us