Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Not able to create new application on Pega 7.1.8

SA-17627

Summary



The developer is not able to create a new application with built on application as Care Management Framework (CMF) 7.13 on Pega  7.1.8 .

Error Messages


A Rule-RuleSet-Version could not be saved due to 1 error(s) on it: .pyRequiresRulesetVersion(8): **PegaFWUI:07-11-99 doesn't exist or is not a valid entry for HVECMFFW:01-01-01


Steps to Reproduce



1. Launch New Application Wizard.
2. Build a new application with build on Application of CMF 7.13 for Pega 7.1.8.


Root Cause



The developer is using CMF 7.13. From 7.13 onwards,  PegaFWUI ruleset is not required, which is a prerequisite for CMF 7.12.
The developer end consists of the old rulesets of HC, as the prerequisite which are not present on the developer rulestack as developer was using 7.13 version.


Resolution



Perform the following local-change steps:

1. Remove the prerequisites in the ruleset validation .
2. Update the old version of HC to the latest ruleset version present in the deployment.
3. Change all of them from ruleset validation to the application validation.

 

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us