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Support Article

Not able to download/open attachments from Custom Mobile App

SA-32112

Summary



On the iOS or Android Pega custom mobile apps, when users try to download attachments using doAttachmentSingleClick, nothing happens. It works properly in the mobile browser.

When users click the link to open the attachment, there is network traffic happening and an entry in console.


Error Messages



Console log message ‘Resource interpreted as Document but transferred with MIME type application/octet-stream’


Steps to Reproduce

  1. Login in to designer studio in pega custom mobile app.
  2. Then launch the end user portal from designer studio.
  3. Then open a WO and try opening an attachment on it.


Root Cause



Designer Studio on custom mobile app is not supported when launched from the end user portal. The newly launched portal opens in a seperate frame which does not have native launchbox context.

Resolution



Log in directly into end user portal in custom mobile app and open the attachments, it will works perfectly fine.

Published February 21, 2017 - Updated October 8, 2020

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