Support Article
Not able to pass call variable while dial transferring
SA-12132
Summary
Trying to pass call variable while dial transferring to another agent. The TransferInitiate activity in ChannelServices-Device-Phone-UI class t was modified o pass the call variable in the XML, but ICM is not able to receive that.
Error Messages
Not Applicable
Steps to Reproduce
Not Applicable
Root Cause
Incorrect syntax:
wrong:
<pagedata><CallData><userOldCallId>14965</userOldCallId><pyCallVariables(5)>0020000022 DEPT</pyCallVariables(5)></CallData></pagedata>
Resolution
Call variable syntax has changed. Notice CallVariable value.
<pagedata><CallData><userOldCallId>14965</userOldCallId><CallVariable5>0020000022 DEPT</CallVariable5></CallData></pagedata>
Tags:
Published July 14, 2015 - Updated December 2, 2021
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