Support Article

Not able to send push notification while using function.

SA-36806

Summary



A custom configuration has been configured with SendNotificationToIOS function to send push notification. In the tracer there are no issues, no failures and no timeouts but on the designated device nothing were received and the test results field was blank.

This environment is having 2 level certificate trust and it looks like the request is not able to pass through these trust certificates.

Production p12 certificate has been applied but still the same unexpected behaviour.



Error Messages



Not Applicable


Steps to Reproduce



1. Open the Pega Marketing portal and navigate to Configuration > Settings > Channels > Push Notification


Root Cause



Multiple tests have been done and apparently the problem was coming from the proxy used on site.

Resolution



I didn't get the full details from the contact but it looks like applying the following setting on the proxy has solved this issue:

-Dhttp.nonProxyHosts=gateway.push.apple.com

Published April 20, 2017 - Updated April 28, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.