Support Article
NullPointerException on navigating to Recent Interactions
Summary
NullPointerException on navigating to the Recent Interactions section on Customer Process Management (CPM).
Error Messages
Caught exception: java.lang.NullPointerException
com.pegarules.generated.activity.ra_action_pzdogridaction_84f3e7348d7bf2bad1ec28065f8afa87.step1_circum0(ra_action_pzdogridaction_84f3e7348d7bf2bad1ec28065f8afa87.java:355)
com.pegarules.generated.activity.ra_action_pzdogridaction_84f3e7348d7bf2bad1ec28065f8afa87.perform(ra_action_pzdogridaction_84f3e7348d7bf2bad1ec28065f8afa87.java:70)
com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3597)
com.pegarules.generated.activity.ra_action_reloadsection_ec27e02b5e2e9a6a6fae844524a68b26.step5_circum0(ra_action_reloadsection_ec27e02b5e2e9a6a6fae844524a68b26.java:756)
Steps to Reproduce
- Log into the CS Insurance portal using the CSInsuranceSysAdmin credentials
- Create a call and navigate to the Interaction Driver. In the Interaction Driver screen, the Recent Interactions section displays all the latest interactions
- Click any one interaction which opens the specific case in Review mode
- Close the review mode to return to the Interaction Driver of the case from which the case was opened and check the Recent Interactions section
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Apply HFix-43990.
Published July 23, 2018 - Updated December 2, 2021
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