Support Article
Older version displays after publishing newer version
Summary
User tags an article (For example, A-1) to a screen. The article displays as a Suggested article. However, when user edits the article (A-1) and publishes the new version (A-2), the A-1 article continues to display as the Suggested article. This occurs while using Pega Knowledge 7.4 on Pega 7.4.
Error Messages
Not Applicable
Steps to Reproduce
- Log in as KM Publisher
- Create an article
- Log in as CSR Manager
- Tag the article to the End User form
- Log in as CSR User to view the article as Suggested article for the screen
- Log in as KM Publisher
- Edit version 1 of the article, add tag and publish it. The version 2 of the article is published
- Log in as CSR User
- Verify if the Suggested article still renders the old content
Root Cause
The D_KMFASuggestedContent data page which uses the D_KMSuggestedContent node level data page to fetch data is used to display the Suggested articles. Since, this page is not removed on editing the Knowledge Management (KM) content, stale data displays. However, there might be a performance impact if the scope of the D_KMSuggestedContent data page is changed. Hence, the latest Knowledge Content Published (KCP) displays on click of a Suggested article.
Resolution
Apply HFix-57223.
Tags:
Published October 22, 2019 - Updated December 2, 2021
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