Skip to main content

Support Article

OnChange SetValue not working in repeating grid text input

SA-11662

Summary



OnChange SetValue not working in repeating grid text input.

Error Messages



Not Applicable

Steps to Reproduce



1. Configure a grid in Read/Write mode.
2. Configure an onChange behaviour to set a value on one of the columns.
3. The property for which the value is being set is not displayed on UI or part of Grid columns.
4. Enter a value and tab out to check, if the set value is updated on clipbaord.



Root Cause



The root cause of this problem is a defect in customer application code/rules. 

As the column/property which is being set is not part of the Grid Display, the value is not posted to the clipboard.



Resolution



This issue is resolved through the following local change: 

Can be resolved by

1) Change the Grid Edit Mode to inline, this makes the row refresh instantaneously and posts the value to the clipboard.
2) Add a new column with the property that is being set and make it's visibility hidden. This way it will not be displayed on UI, however value will be posted to clipboard.
Suggest Edit

Published July 6, 2015 - Updated October 8, 2020

Did you find this content helpful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us