Support Article
Operator menu does not display
SA-57969
Summary
Operator menu does not display on clicking the Operator icon in the Customer Service Interaction portal. This occurs in a single sign-on (SSO) log in session.
Error Messages
Two JavaScript errors occur:
- The reference to pega.u.contextMenu.renderContextMenu was undefined.
- After converting to use new menus (see below), a missing reference to pega.control.menu.showContextMenu
Steps to Reproduce
- Log in with an SSO account.
- Load the Customer Service Interaction portal.
- Click the Operator icon.
Root Cause
An issue in the custom application code or rules.
The application was using the old-style menus. Additionally, customization in the Customer Service header had removed the required reference to pzMenuTemplateInclude.
Resolution
Perform the following local-change:
- Navigate to Designer Studio > User Interface > Application Readiness > HTML5 > UI Elements > Upgrade Show Menu
- Create a custom version of the JSONInclude section rule to reference the missing pzMenuTemplateInclude JavaScript.
Tags:
Published July 23, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.