Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Operator menu does not display

SA-57969

Summary



Operator menu does not display on clicking the Operator icon in the Customer Service Interaction portal. This occurs in a single sign-on (SSO) log in session.


Error Messages



Two JavaScript errors occur:
  1. The reference to pega.u.contextMenu.renderContextMenu was undefined.
  2. After converting to use new menus (see below), a missing reference to pega.control.menu.showContextMenu


Steps to Reproduce

  1. Log in with an SSO account.
  2. Load the Customer Service Interaction portal.
  3. Click the Operator icon.


Root Cause



An issue in the custom application code or rules.
The application was using the old-style menus. Additionally, customization in the Customer Service header had removed the required reference to pzMenuTemplateInclude.



Resolution



Perform the following local-change:
  1. Navigate to Designer Studio > User Interface > Application Readiness > HTML5 > UI Elements > Upgrade Show Menu
     
  2. Create a custom version of the JSONInclude section rule to reference the missing pzMenuTemplateInclude JavaScript.

Published July 23, 2018 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us