Support Article
OperatorID page is cleared
SA-75341
Summary
On launching the Pega application from Pega SalesForce and creating an order, the ApplicationSetup (OOTB) is invoked in which the OperatorID page is cleared.
Error Messages
Not Applicable
Steps to Reproduce
- Launch the Pega applicatoin from the Pega SalesForce.
- Create an order. The ApplicationSetup (OOTB) is invoked and the OperatorID page is cleared.
Root Cause
According to a usecase, the application was switched based on a specific case creation. The application setup activity was invoked in the custom scenario.
The application setup activity was invoked by Pega when a thread was spawned with an application or an application was switched on a thread. The Code-Security.ApplicationProfileSetup can be extended by making changes.
Resolution
The application setup activity need not be invoked explicitly.
Since the setup activity is called by the Pega code automatically, add the custom code after the activity is invoked.
Published August 15, 2019 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.