Support Article
ORA-01005: null password given; logon denied
SA-20173
Summary
An error occurred before ORA-01005: null password given; logon denied error.
Error Messages
ERROR - Couldn't obtain a connection. Refresh the DataSource, and try again
Steps to Reproduce
Unknown
Root Cause
A third-party product issue:
There are no more available connections. The above error is thrown before the ORA-01005 error.
Resolution
Make the following change to the operating environment:
- In the Websphere Admin Console, navigate to Data sources > PegaRULES > WebSphere Application Server data source properties.
- Under Connection Validation Properties, select these items and save the changes.
- Validate new connection
- Validate existing pooled connections
- Navigate to Data sources > PegaRULES > Connection pools.
- Set the maximum number of connections to 100.
Published November 3, 2016 - Updated October 8, 2020
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