Support Article

Oracle Database connecting with incorrect password after change

SA-36988

Summary



User changed the password on the Oracle user, which is used to connect to both the Rules and Data schemas on Oracle.

User also changed this password on the JDBC data source in the WebSphere Console associated with the environment. In WebSphere, the connection tests out correctly.

When user started the application, it starts up abnormally fast, but does not lock out the account.

The first time user browses to the Pega 7 URL associated with this environment, the DBA sees several attempts to connect to the database with an invalid password.

Is it possible that an old password is being cached? Is there a secondary place to store a password for Pega 7?


Error Messages



Not Applicable


Steps to Reproduce

  1. Change password in Oracle database.
  2. Update password in WebSphere app server( WAS).
  3. Navigate to Pega 7 Servlet. Account locks out after several attempts to connect.


Root Cause



A defect or configuration issue in the operating environment.

Resolution



Perform the following local-change:

Restart the deployment manager to ensure that the changes are synchronized between network deployment manager and individual nodes.


Published April 24, 2017 - Updated May 11, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.