Support Article

Output quantities of campaign and segment do not match

SA-38394

Summary



Output quantity of a segment, as verified from the CAMP_COMM_OUT_DET table, does not match with that of the Direct Mail campaign in which it is used.

​Additional requirement is to include records of subscribers whose contracts have expired in the campaign output, which ideally contains only records of subscribers with contracts.


Error Messages



Not Applicable


Steps to Reproduce



Create and schedule a Direct Mail campaign.


Root Cause



The mismatch in quantities of segment and campaign outputs can occur due to the presence of columns in the Extract Template from tables which are not included in the stored fields of the segment and these tables can have no matching records for all the A1 column values present in the segment. The columns of these tables are joined only during the output stage of the campaign.

Resolution

  1. Drag and drop Derived Value to the stored field's grid of the segment.
  2. Create and schedule a new campaign with the updated segment.
To include records of subscribers whose contracts have expired in the campaign output, create separate campaigns for the two criteria.

Published May 23, 2017 - Updated June 6, 2017

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