Support Article
Parameter page used by Agent not reset
SA-8929
Summary
When an Agent processes multiple queue items the parameter values used by the Agent Activity are not reset before processing each new item.
Error Messages
Not Applicable
Steps to Reproduce
Create an Agent which processes lots of items where information is stored on the parameter page.
Root Cause
This is the expected Agent behavior.
Resolution
Agents use the same parameter page to process "ALL" or "max no of items" in one wake-up run.
If you need to reset the parameter page for each new item then this should be done explicitly at the start of the activity.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.