Support Article

Parent case not resolved by AllCoveredResolved ticket

SA-27093

Summary



User made use of AllCoveredResolved ticket in the end shape of a parent case with the expectation that the parent case would resolve when all of its child cases resolved. But this did not happen.

Error Messages



Not Applicable


Steps to Reproduce

  1. Make use of the AllCoveredResolved ticket in the end shape with Resolved-Completed status of parent case starter flow.
  2. Resolve the child case types.
  3. Look for the resolution of the parent case and the child cases. Notice that the parent case is not resolved.


Root Cause



User had made use of AllCoveredResolved ticket in the end shape of the parent case flow. Ticket is only executed if the flow in which "Ticket" is set on one of the shapes is started on the work page.

Advance Flow processing - Limit to the single flow itself, but not for a subflow as well. (For example, you cannot jump to the subflow from the parent flow by raising a ticket.)
If you are trying to advance (jump) to a shape in a subflow, this will not happen because the subflow is not yet started. Ticket is only processed if the flow in which "Ticket" is set on one of the shapes is started on the work page.

Back And Forth - Limit to a single stage and not across stages of flows. (You cannot raise a ticket from a later stage to earlier stage in which the ticket is referenced.)
Ticket is only processed if the flow in which "Ticket" is set on one of the shapes is started on the work page.


Resolution

  1. Add a utility shape before the end shape of the parent case flow to update the status of the parent case to Resolved-Complete.
  2. Set the AllCoveredResolved ticket on the utility shape.

Published August 23, 2016 - Updated February 1, 2018


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