Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Parse XML not working after switching from DB2 to Oracle

SA-71641

Summary



When moving to a new system, unable to parse XML rules. This works on the existing systems. The repeating groups in the rule display only the first element; whereas in the earlier system, all the elements are visible.


Error Messages



Not Applicable


Steps to Reproduce



Create a tri-level rule as below.



In the new system, the Policy does not expand and the data is missing.




Root Cause



A defect in Pegasystems’ code or rules.


Resolution



Perform the following local-change:

Set the Dynamic System Setting (DSS) entry SwitchToOldAssembler to 'true' to revert to the PRPC 6.3 assembler.

Owning Ruleset: Pega-IntegrationEngine
Setting Purpose: SwitchToOldAssembler

Published March 29, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us