Support Article

Passivation directory names are too long

SA-25515

Summary



System was upgraded from PRPC 6.2 SP1 to Pega 7.1.9 in production and after that the passivation directories are getting generated with HTML escape codes instead of certain characters.
Unable to delete these files manually.


Error Messages



Not applicable.


Steps to Reproduce



1. Run a tool similar to APP Scan, which creates multiple requests by modifying the URL.
2. Make sure that Passivation is enabled and set to default value that is file and timeout period is less.


Root Cause



User has configured an operator, using which they were running a security tool (APP Scan), which has created multiple HTTP requests by including special characters in the request.

When those sessions got passivated, as the directory name would be based on the thread name, directories got created with special characters.

Resolution



Disable the process which is responsible for creating the HTTP requests in the production environment.
It is not recommended to conduct such tests in production environment, as it would effect the processing time of other requests.
If such a test has to be conducted, ensure that passivation is disabled or the passivation timeout has been increased.

 

Published July 12, 2016 - Updated July 28, 2016

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.