Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega 7 platform and Pega 8 platform render a browser differently

SA-87520

Summary



Pega 7 platform and Pega 8 platform render browsers differently.


Error Messages



Not Applicable


Steps to Reproduce

  1. Launch any object in the Pega portal.
  2. View the 'Preview' from the Developer Tools. In Pega 7.1, content is returned. However, in Pega 8, the tab is blank.


ROOT  CAUSE

This behavior is as per Pega product design.


Resolution



Here’s the explanation for the reported behavior: 

In Pega 7.1, HTML markup is returned in the response. When the Preview tab from the Developer Tools is used to view the response, the response displays as an HTML page or a form.

However, in Pega 8.1, instead of HTML markup, meta data (in the JSON format) is returned. This is used by the client to render the UI. When this is viewed in the Preview tab of the Developer tools, the response displays as a JavaScript code.

Technical enhancements are made from Pega 7.4 onwards.
Suggest Edit

Published December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us