Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega 7.1.8 application not accessible in Websphere

SA-19346

Summary



Pega 7.1.8 application deployed in Websphere application server is not accessible.

Error Messages



1. 0000008e webapp        E com.ibm.ws.webcontainer.webapp.WebApp logServletError SRVE0293E: [Servlet Error]-[WebStandard]:    com.ibm.ws.webcontainer.webapp.WebAppErrorReport: PegaRULES server not available
.
.
    at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1881)

2. 000000a2 AppServerBrid E com.pega.pegarules.boot.internal.extbridge.AppServerBridgeToPega  Problem during method invocation (init)
 java.lang.NoClassDefFoundError: com.pega.pegarules.pub.util.PRFile
.
.
 

Steps to Reproduce



Start the application deployed in Websphere.

Root Cause



Misconfiguration of the data source in application server and problem with the database server resulted in this issue.

Resolution



Setup the data source as per Pega installation document guideline and user setup new Rules Database.

Published February 11, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us