Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega 8 Aria markup not generated from within a repeating grid

SA-86563

Summary



Pega Platform 7.2 is upgraded to Pega Platform 8.2. On launching a screen in a modal window from within a repeating grid, the new Pega 8 Aria markup is not present. Instead, the markup from Pega Platform 7.2 is present.

For example:
  • When a modal window is launched from a button outside of a repeating grid, and if a required field and label are inspected, the label contains the class icon-required and data-required="*". The field contains the aria-required="true" tag.
  • When a modal window is launched from a button within a repeating grid, and if a required field and label are inspected, the label contains the class iconRequired and required-field-accessibility>Required. The field does not contain an aria-required tag.

Before the upgrade:



After the upgrade:




Error Messages



Not Applicable


Steps to Reproduce

  1. Log in to accessibility enabled user.
  2. Launch the modal dialog from within the grid and from outside the grid. Verify the markup.


Root Cause



A defect in Pegasystems’ code or rules.


Resolution



Update to Pega Platform 8.2.3.
Suggest Edit

Published August 16, 2019 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us