Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega 8.3 Development system does not start after a fresh install

SA-87343

Summary

Unable to start Pega Platform 8.3 after fresh installation.

Error Messages

ERROR   - Cannot start service [StreamServer.Default]. Will retry in 180 seconds. Remaining attempts: 2
org.jboss.netty.channel.ChannelException: Failed to bind to: /127.0.0.1:7003 
at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:272) ~[netty-3.10.6.Final.jar:?]

Steps to Reproduce

Start the Application server.

Root Cause

Port 7003 is already in use and is unable to bind.

Resolution

Perform the following local-change:

  1. Create a DSS (Dynamic System Setting) with the following options:

    – Owning Ruleset: Pega-Engine
    – Setting Purpose: prconfig/dsm/services/stream/pyPort/default
    – Value: 7005 (other than port 7003)

     
  2. Restart the server.

Published December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us