Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega API cases PUT doens't work (known defect), request hotfix

SA-84897

Summary



Pega Cases API processes the PUT method incorrectly.


Error Messages



API error: pyUpdateCaseDetails is not part of assignment actions


Steps to Reproduce

  1. Create a case.
  2. Open the Service REST rule.
  3. In the Service REST rule, click Actions and select Run.
  4. Fill in the pzInsKey of the case at the 'ID' prompt to execute a GET call for the created case.
  5. Copy the etag from the response.
  6. Fill in the obtained etag in the 'if-match' prompt to execute a PUT call for the created case. Perform this while setting new content in the 'Message Buffer' field.


Root Cause



An issue in the custom application code or rules.
pyUpdateCaseDetails was not a part of the case.



Resolution



Perform the following local-change:

Add pyUpdateCaseDetails as a case wide local flow action.

Published December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us