Support Article
Pega Chat and Co-Browse do not work from the Interaction Driver
SA-65352
Summary
Pega Chat 7.4 and Pega Co-Browse 7.4 do not work when initiated from the Interaction Driver of a case. However, these applications work when initiated from the first screen of the Chat case created.
On closing the case, the case does not hang; however, the applications do not work. Additionally, the same issue occurs when using an out-of-the-box operator.
Error Messages
[WebContainer : 5] [OpenPortal] [ ] [abc:07.40] (internal.mgmt.Executable) ERROR 127.0.0.1| - Exception
java.lang.NullPointerException
at com.pegarules.generated.activity.ra_action_performpreprocessing_e6b3b65d6cb30cfcf9e810702cbc668a.step1_circum0(ra_action_performpreprocessing_e6b3b65d6cb30cfcf9e810702cbc668a.java:173) ~[?:?]
at com.pegarules.generated.activity.ra_action_performpreprocessing_e6b3b65d6cb30cfcf9e810702cbc668a.perform(ra_action_performpreprocessing_e6b3b65d6cb30cfcf9e810702cbc668a.java:70) ~[?:?]
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3421) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10794) ~[prprivate.jar:?]
at com.pegarules.generated.activity.ra_action_processaction_05236e30aa52921c2bc77f906e8e8d64.step18_circum0(ra_action_processaction_05236e30aa52921c2bc77f906e8e8d64.java:1880) ~[?:?]
at com.pegarules.generated.activity.ra_action_processaction_05236e30aa52921c2bc77f906e8e8d64.perform(ra_action_processaction_05236e30aa52921c2bc77f906e8e8d64.java:354) ~[?:?]
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3421) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.mgmt.base.ThreadRunner.runActivitiesAlt(ThreadRunner.java:646) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.mgmt.PRThreadImpl.runActivitiesAlt(PRThreadImpl.java:484) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.engineinterface.service.HttpAPI.runActivities(HttpAPI.java:3467) ~[prprivate.jar:?]
at com.pega.pegarules.session.external.engineinterface.service.EngineAPI.processRequestInner(EngineAPI.java:417) ~[prenginext.jar:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0-internal]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:95) ~[?:1.8.0-internal]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55) ~[?:1.8.0-internal]
at java.lang.reflect.Method.invoke(Method.java:508) ~[?:2.6 (07-13-2016)]
Steps to Reproduce
- Log in to the Customer Process Manager (CPM) using an access group that points to CustomerServiceForInsurance application
- Log in to Pega Chat after logging in to the portal.
- Initiate a chat from a website. A case is created on the CPM (as below).
- Select a Contact and submit the case. The case is routed to the Interaction driver screen.
- Enter some text in the Chat window in the website. The text entered in the website freezes in the chat window on CPM and text entered later does not display.
- Click End Chat from the options.
Pega Co-Browse
- Perform Steps 1 to 4 as above.
- Select the Co-Browse option from the Actions dropdown on the Chat window. The user in the website accepts the Co-Browse request. On the CPM, the session is not established and hangs.
Root Cause
A defect in Pegasystems’ code or rules.
Issue in the refresh timing in the CPMDialog section rule that belongs to PegaCA-Work-Interaction-Chat class.
Resolution
Apply HFix-46190.
Published October 7, 2018 - Updated December 2, 2021
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