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Support Article

Pega CSFS Collection case is not opening

SA-27639

Summary



Using the default portal on CSFS strategic application, a dedicated "Collection Cases" tab can be found:



Clicking the yellow line above, should open the corresponding case:



But unfortunately, this action isn't working, the system reloads the main portal and the case selected never gets opened after clicking.
 


Error Messages



No error message but cases cannot be opened.


Steps to Reproduce



1) Customize the configuration in order to use JavaScript Function launchResearchItem



2) Install HFix-24022 first, then installed the new pacakge HFix-24411.
3) Log into the normal portal.
4) Click the Collection Case tab.
5) Click a collection case to open it.
6) Observe that nothing occurs.

 


Root Cause



The custom configuration is using the JavaScript function called "launchResearchItem" but this function has not been loaded by the harness so it does not work as expected.

Resolution



In order to make it work and to handle "Collection Cases" actions, a JavaScript bundle called 'pega_cpm_IP_EventManager' needs to be added to the Harness in the "Scripts and Styles" tab:

 

Published September 22, 2016 - Updated December 2, 2021

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